HDOJ5522Numbers

Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/262144 K (Java/Others)
Total Submission(s): 88    Accepted Submission(s): 67


Problem Description
There are n numbers  A1,A2....An ,your task is to check whether there exists there different positive integers i, j, k ( 1i,j,kn ) such that  AiAj=Ak
 

Input
There are multiple test cases, no more than 1000 cases.
First line of each case contains a single integer n. (3n100) .
Next line contains n integers  A1,A2....An . (0Ai1000)
 

Output
For each case output "YES" in a single line if you find such i, j, k, otherwise output "NO".
 

Sample Input
  
  
3 3 1 2 3 1 0 2 4 1 1 0 2
 

Sample Output
  
  
YES NO YES
 

Source
 

Recommend
hujie

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int vis[2010];
int num[110];
int main()
{
    int i,j,k=1,n;
    while(scanf("%d",&n)!=EOF){
        memset(vis,0,sizeof(vis));
        for(i=0;i<n;++i){
            scanf("%d",&num[i]);
            vis[num[i]]++;
        }
        int flag=0;
        for(i=0;i<n&&flag==0;++i){
            for(j=0;j<n&&flag==0;++j){
                if(i==j)continue;
                if(vis[num[i]+num[j]]){
                    vis[num[i]]--;
                    vis[num[j]]--;
                    if(vis[num[i]+num[j]]){
                        flag=1;break;
                    }
                    vis[num[i]]++;
                    vis[num[j]]++;
                }
            }
        }
        if(flag){
            printf("YES\n");
        }
        else {
            printf("NO\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值