An Easy Problem

An Easy Problem

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述
    In this problem, you are given two integers L and R, and your task is to calculate the sum of all the number's square between L and R(inclusive).
输入
The first line contains an integer T, indicates the number of test case.
The next T lines, each line contains two integers L and R(1≤L,R≤10^5).
输出
Print an integer represents the sum.
样例输入
2
1 2
2 4
样例输出
5
29

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		int times = scanner.nextInt();
		while (times-- != 0) {
			long start = scanner.nextInt();
			long end = scanner.nextInt();
			BigInteger result = BigInteger.ZERO;
			if (start > end) {
				long temp = end;
				end = start;
				start = temp;
			}
			for (long i = start; i <= end; i++) {
				result = result.add(BigInteger.valueOf(i * i));
			}
			System.out.println(result);
		}
	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值