cakes

cakes

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 0
描述
there are some naughty little cakes(less than 1000), each cake has a numberthey stand in plates whose number start from 0 increasing in turn . The process of waiting for being taste by small Q is very boring so they made a game .According to the serial numbers of the cake from small to large lying on a plate ,but they forgot the plates that they lying before, if they don't go back, small Q will be very angry.So, smart programmer monkey  can you help them?
输入
Multiple sets of test data
first give you a digsit the number of cakes;
then there are n digsits
输出
。。。
样例输入
4
4 2 1 3
5
4 3 1 2 5
样例输出
2 1 3 0
2 3 1 0 4
提示
maybe they are equal to others,if so ,printf the order before

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		while (scanner.hasNext()) {
			int number = scanner.nextInt();
			int arr[] = new int[number + 5];
			int vis[] = new int[number + 5];
			for (int i = 0; i < number; i++) {
				arr[i] = scanner.nextInt();
				vis[i] = i;
			}
			for (int i = 0; i < number - 1; i++) {
				for (int j = 0; j < number - 1 - i; j++) {
					if (arr[j] > arr[j + 1]) {
						int temp = arr[j];
						arr[j] = arr[j + 1];
						arr[j + 1] = temp;

						temp = vis[j];
						vis[j] = vis[j + 1];
						vis[j + 1] = temp;
					}
				}
			}
			for (int i = 0; i < number; i++) {
				System.out.print(vis[i] + " ");
			}
			System.out.println();
		}
	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值