E - Cakes and Donuts

E - Cakes and Donuts

La Confiserie d’ABC sells cakes at 4 dollars each and doughnuts at 7 dollars each. Determine if there is a way to buy some of them for exactly N dollars. You can buy two or more doughnuts and two or more cakes, and you can also choose to buy zero doughnuts or zero cakes.

Constraints
N is an integer between 1 and 100, inclusive.

Input
Input is given from Standard Input in the following format:

N

Output
If there is a way to buy some cakes and some doughnuts for exactly N dollars, print Yes; otherwise, print No.

Sample Input 1
11

Sample Output 1
Yes
If you buy one cake and one doughnut, the total will be 4+7=11 dollars.

Sample Input 2
40

Sample Output 2
Yes
If you buy ten cakes, the total will be 4×10=40 dollars.

Sample Input 3
3

Sample Output 3
No

The prices of cakes (4 dollars) and doughnuts (7 dollars) are both higher than 3 dollars, so there is no such way.

代码:

#include <bits/stdc++.h>
using namespace std;
int n;
int main()
{
    cin>>n;
    bool f=false;
    for(int i=0;i<=25;i++){
        for(int j=0;j<=14;j++){
            if(4*i+7*j==n){
                f=true;
                break;
            }
        }
    }
    if(f)
        cout<<"Yes";
    else
        cout<<"No";
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值