1049 Counting Ones(30 分)

113 篇文章 9 订阅

1049 Counting Ones(30 分)

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤2​30​​).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5

题目大意:给出一个数字n,求1~n的所有数字里面出现1的个数
分析:这是一道数学问题。从第一位(个位)到最高位,设now为当前位的数字,left为now左边的所有数字构成的数字,right是now右边的所有数字构成的数字。只需要一次次累加对于当前位now来说可能出现1的个数,然后把它们累加即可。a表示当前的个位为1,十位为10,百位为100类推。
对于now,有三种情况:
1.now == 0 : 那么 ans += left * a; //因为now==0说明now位只有在left从0~left-1的时候会产生1,所以会产生left次,但是又因为右边会重复从0~999…出现a次
2.now == 1 : ans += left * a + right + 1;//now = 1的时候就要比上一步多加一个当now为1的时候右边出现0~right个数导致的now为1的次数
3.now >= 2 : ans += (left + 1) * a;//now大于等于2就左边0~left的时候会在now位置产生1,所以会产生left次,但是又因为右边会重复从0~999…出现a次

关于以上,如有问题可以参考另一个链接:https://blog.csdn.net/qq_29762941/article/details/82469301

#include<iostream>
using namespace std;


int main(){
	int n,round,weight,former,base = 1;
	cin>>n;
	int temp = n;
	int count = 0;
 	while(temp > 0){
 		weight = temp%10;
 		temp /= 10;
 		former = n%base;
 		round = n/(10*base);
 		if(weight == 0)
 			count += (round*base);
 		else if(weight == 1)
 			count += (round*base + former + 1);
 		else if(weight > 1)
 			count += (round*base + base);
 		base *= 10;
 	}
 	cout<<count<<endl;
	
	
	return 0;
}

以下放一个大数相加来解题的代码,但不是AC本题的正确代码,仅是提供一种大数相加的操作:

#include<iostream>
using namespace std;

void add(string &str){
	int flag = 0;
	int num = (str[str.size()-1] - '0') + 1;//模拟数字加一 
	if(num >= 10){
		num -= 10;
		flag = 1;
	}
	str[str.size()-1] = '0' + num;
	
	for(int i=str.size()-2;i>=0;i--){
		num = (str[i] - '0') + flag;
		flag = 0;
		if(num >= 10){
			num -= 10;
			flag = 1;
		}else{
			str[i] = '0' + num;
			break;
		}
		str[i] = '0' + num;
	}
	if(flag == 1)
		str = '1' + str;
}

int getcount(string &str){
	int count = 0;
	for(int i=0;i<str.size();i++)
		if(str[i] == '1')
			count++;
	return count;
}

int main(){
	string str,temp;
	cin>>str;
	temp = '1';
	int count = 0;
	while(temp != str){
		count += getcount(temp);
		add(temp);
	}
	count += getcount(temp);
	cout<<count<<endl;
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值