PAT甲级 1089 Insert or Merge (25 分)排序模拟(直插排序与非递归归并排序)

113 篇文章 9 订阅
8 篇文章 0 订阅

1089 Insert or Merge (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the Nnumbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

解题思路:本题要完全模拟插入排序和归并排序
本题一个要点是,判断序列是某种算法的中间序列之后,还要再输出此方法下一轮的序列。 
可以在排序方法中添加一个标志flag,每一轮前判断两个序列是否相等,相等则flag=true;而每一轮操作后,再判断标志flag是否=true。 

注意: 题中的归并排序并非递归形式的,所以要用非递归归并算法完成!

#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;

vector<int> fir,res,temp;
int n;
bool insertSort(vector<int> &arr,int n){
    int i,j;
    bool flag = false;
    for(i=1;i<n;i++){
    	if(i != 1 && arr == res){
            flag = true;
        }
        int temp = arr[i];
        for(j=i-1;j>=0 && arr[j]>temp;j--){
               arr[j+1] = arr[j];
        }
        arr[j+1] = temp;
        if(flag){
        	cout<<"Insertion Sort"<<endl;
        	for(int i=0;i<n;i++)
        		printf("%d%s",arr[i],i==n-1?"":" ");
        	return true;
        }
    }
    return false;
}
void Merge(vector<int> &arr,vector<int> &temp,int l,int mid,int r){
    int i = l,j = mid+1;
    int k = 0;
    while(i<=mid && j<=r){
        if(arr[i]<=arr[j])
            temp[k++] = arr[i++];
        else
            temp[k++] = arr[j++];
    }
    while(i<=mid){
        temp[k++] = arr[i++];
    }
    while(j<=r){
        temp[k++] = arr[j++];
    }
    for(int i=0;i<k;i++)
        arr[l+i] = temp[i];
}

bool mergeSort(vector<int> &arr,vector<int> &temp,int l,int r){
	int cnt = 0;
	bool flag = false;
	for(int step = 2;step / 2 <= n;step *= 2)//注意最后一次归并需要step/2<=n,保证i+step-1至少含所有元素 
	{
		
		if(step != 2 && arr == res)
			flag = true;
		for(int i=0;i<n;i += step)//完成0-1、2-3、4-5等操作 
		{	
			int mid = i+ step/2 -1;//需要-1才能正确对应Merge需要的mid,如2-3时,i=0,step=2,mid需要2
			if(mid+1 < n)//保证有右边的元素
				Merge(arr,temp,i,mid,min(i+step-1,n-1));
		}
		if(flag){
	       	cout<<"Merge Sort"<<endl;
	        for(int i=0;i<n;i++)
	        	printf("%d%s",arr[i],i==n-1?"":" ");
	        return true;
       	}
	}
	return false;
}

int main()
{
    cin>>n;
    fir.resize(n);res.resize(n),temp.resize(n);
    for(int i=0;i<n;i++)
        cin>>fir[i];
    for(int i=0;i<n;i++)
        cin>>res[i];
    vector<int> arr = fir;
    if(insertSort(arr,n) == false){
    	 arr = fir;
    	 mergeSort(arr,temp,0,n-1);
    }
    
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值