PAT甲级 1096 Consecutive Factors (20 分)

113 篇文章 9 订阅

1096 Consecutive Factors (20 分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

题目大意: 输入一个数,要求输出最大连续因素乘积。若有相同长度的,则输入最小序号的。

注意: 题目并不是要求 最大连续因素乘积 与 输入数相等,只要是连续最长的因数即可。

#include <iostream>
#include <cmath>
#include <cstdio> 
using namespace std;
long int num, temp;

int main(){
    cin >> num;
    int cnt = 0;
    int maxlen = 0,start = 0;
    for(int i=2;i<=sqrt(num);i++){
    	if(num%i == 0){
    		int a = num,b = i;
    		int n = 0;
    		while(a%b == 0){
    			a /= b;
    			b++;
    			n++;
    		}
    		if(maxlen < n){
    			maxlen = n;
    			start = i;
    		}
    	}
    } 
    if(maxlen == 0){
    	printf("1\n");
    	printf("%d",num); 
    }else{
    	printf("%d\n",maxlen);
    	for(int i=0;i<maxlen;i++){
    		printf("%d%s",start+i,i!=maxlen-1?"*":""); 
    	}
    }
    
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值