PAT A1096 算法笔记 Consecutive Factors 测试点3

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

记录这道题主要是因为我最开始测试3死活过不去!


测试点3的数据如下:

输入:

60

输出:

3
3*4*5

先讲一讲为什么我最开始测试点3过不去

我最开始的思路是判断某个数如果是他的因子,再判断下一个,如果也是他的因子且两数相乘的积小于N,则继续判断下一个,如果下一个仍然是他的因子且三个数的乘积也小于N则继续判断……

例如

5是630的因子,且5小于630,继续判断

6是630的因子,且30小于630,继续判断

7是630的因子,且30小于630,继续判断

8不是630的因子,结束本轮判断,本轮的长度为3->5*6*7

但是这样判断是不正确的!

比如60

2是60的因子,且2小于60,继续判断

3是60的因子,且6小于60,继续判断

4是60的因子,且24小于60,继续判断

5是60的因子, 但是120大于60,结束判断,本轮长度为3->2*3*4(实际应该是3*4*5)

实际上2*3*4 == 24,而24根本不是60的因子,之前的逻辑中的小于N是不正确的。

正确的逻辑应当是,从每一个能整除N的数k开始找到最大的i,使k*(k+1)*(k+2)*……*(k+i)能整除N。

AC的代码如下:

#include <stdio.h>
#include <math.h>


bool isPrime(long long n)
{
	if(n <= 1) return false;
	for(long long i = 2; i <= (long long)sqrt(1.0 * n); i++)
	{
		if(n % i == 0) return false;
	}
	return true;
}

int main()
{
	long long n, cnt = 0, maxcnt = 0, last;
	scanf("%lld", &n);
	
	if(isPrime(n))
	{
		printf("1\n%lld", n);
	}
	else
	{
		long long cur = 1;
		for(long long i = 2; i <= (long long)sqrt(1.0 * n) + 1; i++)
		{
			if(n % i == 0)
			{
				long long j = i;
				while(true)
				{
					cur *= j;
					if(n % cur == 0)
					{
						cnt++;
					}
					else
					{
						if(maxcnt < cnt)
						{
							maxcnt = cnt;
							last = j -1;
						}
						cnt = 0;
						cur = 1;
						break;
					}
					j++;
				}
			}
			
//			if(n % i == 0 && cur * i < 0)
//			{
//				cur *= i;
//				cnt++;
//			}
//			else
//			{
//				if(maxcnt < cnt)
//				{
//					maxcnt = cnt;
//					last = i - 1;
//				}
//                cur = 1;
//				cnt = 0;
//			}
		}
		
		printf("%lld\n", maxcnt);
		for(long long i = maxcnt; i > 0; i--)
		{
			printf("%lld", last - i + 1);
			if(i != 1) printf("*");
		}
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值