HD 2120 Ice_cream's world I 【并查集】

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 894    Accepted Submission(s): 522


Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
  
  
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
  
  
3
AC代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int pre[1001],n;
void init()
{
	for(int i=0;i<n;i++)
	pre[i]=i;
}
int find(int x)//必须要用压缩路径,不用压缩路径过不了。-.-  
{
	if(pre[x]!=x)
	{
		pre[x]=find(pre[x]);
	}
	return pre[x];
}
int join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx==fy)
	{
		return true;
	}
	else
	{
		pre[fx]=fy;
		return false;
	}
}
int main()
{
	int m,a,b,ans;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		ans=0;
		init();
		for(int i=0;i<m;i++)
		{
			scanf("%d %d",&a,&b);

			if(join(a,b))
			{
				ans++;
			}
		}
		printf("%d\n",ans);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值