poj--2083--Fractal(dfs)

75 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 30000KB 64bit IO Format: %I64d & %I64u

Status

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.
A box fractal is defined as below :
  • A box fractal of degree 1 is simply
    X
  • A box fractal of degree 2 is
    X X
    X
    X X
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following
    B(n - 1)        B(n - 1)
    
     B(n - 1)
    
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-


输入的数表示的其实就是有几大层,在dfs里设置的五个语句,可以表示逐层查找,而第n层的元素是n-1层的,看图就知道,逐个找到,左上角的‘X’,
然后在递归中将每一层遍历出来,列个表会好一些

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char map[1010][1010];
int POW(int n,int m)
{
	int ans=1;
	for(int i=1;i<=m;i++)
	ans*=n;
	return ans;
}
void dfs(int n,int x,int y)
{
	if(n==1)
	{
		map[x][y]='X';
		return ;
	}
	int ans=POW(3,n-2);
	dfs(n-1,x,y);
	dfs(n-1,x,y+(ans<<1));
	dfs(n-1,x+ans,y+ans);
	dfs(n-1,x+(ans<<1),y);
	dfs(n-1,x+(ans<<1),y+(ans<<1));
}
int main()
{
	int n;
	while(scanf("%d",&n),n!=-1)
	{
		int ans=POW(3,n-1);
		for(int i=0;i<ans;i++)
		{
			for(int j=0;j<ans;j++)
			{
				map[i][j]=' ';
			}
		}
		dfs(n,0,0);
		for(int i=0;i<ans;i++)
		{
			map[i][ans]='\n';
			printf("%s",map[i]);
		}
		printf("-\n");
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值