Street Lamps

C. Street Lamps

 

Bahosain is walking in a street of Nblocks. Each block is either empty or has one lamp. If there is a lamp in a block, it will light it’s block and the direct adjacent blocks. For example, if there is a lamp at block 3, it will light the blocks 2, 3, and 4.

 

Given the state of the street, determine the minimum number of lamps to be installed such that each block is lit.

 

Input

 

The first line of input contains an integer T(1  T  1025)​that represents the number of test cases.

 

The first line of each test case contains one integer N​ (1  N  100)​that represents the number of blocks in the street.

 

The next line contains N​characters, each is either a dot ’.’or an asterisk ’*’.

 

A dot represents an empty block, while an asterisk represents a block with a lamp installed in it.

 

Output

 

For each test case, print a single line with the minimum number of lamps that have to be installed so that all blocks are lit.

 

 

 

Sample Input

Sample Output

3

2

6

0

......

1

3

 

*.*

 

8

 

.*.....*

 



思维题,想通了其实很简单的~~

把'*'能照到的地方换成'!',那么只有'.'的地方需要安装灯泡了,注意3个'.'需要一个灯泡,4个'.'就要两个才行了,所以计算的时候要加个2,再除以3。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int t,n;
    char a[105];
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        scanf("%d",&n);
        getchar();//这个一定要!!!
        for(int i=0; i<n; i++)
            scanf("%c",&a[i]);
        for(int i=0; i<n; i++)
        {
            if(a[i]=='*')
            {
                if(i==0)
                {
                    if(a[i+1]=='.')
                        a[i+1]='!';
                }
                if(i==n-1)
                {
                    if(a[i-1]=='.')
                        a[i-1]='!';
                }
                else
                {
                    if(a[i-1]=='.')
                        a[i-1]='!';
                    if(a[i+1]=='.')
                        a[i+1]='!';
                }
            }
        }
        int ans=0,sum=0;
        for(int i=0; i<n; i++)
        {
            if(a[i]=='.')
                sum++;
            else
            {
                ans+=(sum+2)/3;
                sum=0;
            }
        }
        ans+=(sum+2)/3;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值