ACM Amman Collegiate Programming Contest C. Street Lamps

C. Street Lamps

 

Bahosain is walking in a street of Nblocks. Each block is either empty or has one lamp. If there is a lamp in a block, it will light it’s block and the direct adjacent blocks. For example, if there is a lamp at block 3, it will light the blocks 2, 3, and 4.

 

Given the state of the street, determine the minimum number of lamps to be installed such that each block is lit.

 

Input

 

The first line of input contains an integer T(1  T  1025)​that represents the number of test cases.

 

The first line of each test case contains one integer N​ (1  N  100)​that represents the number of blocks in the street.

 

The next line contains N​characters, each is either a dot ’.’or an asterisk ’*’.

 

A dot represents an empty block, while an asterisk represents a block with a lamp installed in it.

 

Output

 

For each test case, print a single line with the minimum number of lamps that have to be installed so that all blocks are lit.

 

 

 

Sample Input

Sample Output

3

2

6

0

......

1

3

 

*.*

 

8

 

.*.....*

 

     题意:给出一个字符串,每个'*'相当于灯,它能照亮相邻两格,每个'.'代表没有灯的格子。问:至少还需要多少个灯才能照亮整条路。

     解题思想:这个题是个模拟题。我的思路是先对字符串进行一次扫描,将所有带'*'的左右两格都点亮,然后再扫描一次,每三个'.'需要一个灯来点亮。于是,我创了一个flag数组来存整条路,0代表没照亮,1代表灯,2代表被灯照亮的地方。然后再对这个flag数组进行处理,遇到0区间段,小于三个连续的0,记一个,大于三个连续的0,即用0的个数除以3即可(取整)。以下是我的代码

#include <stdio.h>

int main()
{
    //freopen("in.txt","r",stdin);
    int t,n;
    char light[105];
    int arr[105];
    scanf("%d",&t);
    while(t--)
    {
        for(int i=0;i<105;i++)
            arr[i]=0;
        scanf("%d",&n);
        scanf("%s",light);
        for(int i=0; i<n; i++)
        {
            if(light[i]=='*')
            {
                if(i>=1) arr[i-1]=2;
                arr[i]=1;
                arr[i+1]=2;
            }
        }
        int sum=0,temp=0;
        for(int i=0; i<n; i++)
        {
            if(!arr[i]) temp++;
            else
            {
                if(temp>0)
                {
                    sum=sum+temp/3;
                    if(temp%3) sum++;
                    temp=0;
                }
            }
        }
        if(temp>0)
        {
            sum=sum+temp/3;
            if(temp%3) sum++;
            temp=0;
        }
        printf("%d\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值