直角坐标系(Java)

Problem Description

X是一个喜欢数学的小孩,现在他刚刚学了坐标系。他想知道点(X,Y)在第几象限内。输入数据保证点不在坐标轴及原点上。

Input

 多组输入。

每组输入两个整数X,Y,代表点(X,Y),中间用空格隔开。

Output

 输出一个整数代表点在第几象限内。

Sample Input

2 3
-2 -3

Sample Output

1
3

Java版:

import java.util.Scanner;
public class Main {
 
	public static void main(String[] args) {
     Scanner in = new Scanner(System.in);
     int a,b;
     while(in.hasNext()) {
    	 a = in.nextInt();
    	 b = in.nextInt();
    	 if(a>0&&b>0) {
    		 System.out.println("1");
    	 }
    	 else if(a>0&&b<0)
    		 System.out.println("4");
    	 else if(a<0&&b>0)
    		 System.out.println("2");
    	 else if(a<0&&b<0)
    		 System.out.println("3");

     }
    }
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

FawkesDoris

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值