solution Of 1096. Consecutive Factors (20)

48 篇文章 0 订阅

1096. Consecutive Factors (20)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

**Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1,2^31).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format “factor[1]factor[2]…*factor[k]”, where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
5*6*7


结题思路 :
题意要求我们找到对于一个数的因式分解中可能出现的最长因子序列。
要求1:因子中不包括1;
要求2:题目提供的case的因子3极其误导力,开始以为这个3表示后面还有3个数,其实仅作为因子在遇到3以后,下一个应该是4,但是此时4已经无法整除(630/3),故此时的长度仅有1。

程序步骤:
第一步、我们先拿到第一个可以整除value的除数divider;
第二步、为了统计最长的连续因子,对divider做累加,并更新被除数,直到余数!=0;
第三步、记录连续因子的其实位置,并根据条件更新起始位置;
第四步、输出即可。

具体程序(AC)如下:

#include <iostream>
#include <cmath>
using namespace std;
int main() {
    int value;
    cin>>value;
    int m=sqrt(value);
    int consecutive=0;
    int tmpV;
    int count;
    int divider;
    int start=-1;
    for(int i=2;i<=m;++i)
    {
        tmpV=value;
        count=0;
        divider=i;
        while(tmpV%divider==0)
        {
            count++;
            tmpV=tmpV/divider;
            divider++;
        }
        if(divider-i>consecutive)
        {
            consecutive=divider-i;
            start=i;
        }
    }
    if(consecutive==0)
        cout<<1<<endl<<value<<endl;
    else
    {
        cout<<consecutive<<endl<<start;
        for(int i=1;i<consecutive;++i)
            cout<<"*"<<++start;
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值