solution Of 1095. Cars on Campus (30)

48 篇文章 0 订阅

1095. Cars on Campus (30)

Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each “in” record is paired with the chronologically next record for the same car provided it is an “out” record. Any “in” records that are not paired with an “out” record are ignored, as are “out” records not paired with an “in” record. It is guaranteed that at least one car is well paired in the input, and no car is both “in” and “out” at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09


结题思路 :
题意要求我们书好处给出时间点的校园车辆的数量和停靠时间最长的车辆信息。
要求1:相同车辆的连续的in记录只取最后一条,out记录只取第一条,要求in和out数据必须相邻,其余为非法数据;
要求2:一开始对每辆车和他的进出记录保存为map < string,vector < car > >,再进行统计,但发现有一个case超时;

程序步骤:
第一步、对输入数据进行排序(车牌,时间,进出记录);
第二步、过滤非法数据,同时记录对时间数组进行填写,对相邻的记录的时间间隔进行记录;
第三步、对时间数组求其前缀合;
第四步、输出对应时间点的停车辆数;
第五步、输出停车时间最长的车辆信息。

具体程序(AC)如下:

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#define day 3600*24
using namespace std;
struct node{
    string id;
    int time;
    int in;
};
map<string,int>name2Duration;
map<string,int>::iterator pointDuration;
vector<node> actList;
vector<node*> actListP;
vector<int> stamps(day,0);
int cmp(const node* a,const node* b)
{
    if(a->id!=b->id)
        return a->id<b->id;
    if(a->time!=b->time)
        return a->time<b->time;
    return a->in>b->in;
}
int time2Int(string a)
{
    return ((a[0]-'0')*10+(a[1]-'0'))*3600+((a[3]-'0')*10+a[4]-'0')*60+(a[6]-'0')*10+a[7]-'0';
}
void filterAndFill(vector<node*>& a)
{
    int duration=0;
    for(int i=0;i<int(a.size())-1;++i)
    {
        if(a[i]->id==a[i+1]->id&&a[i]->in==1&&a[i+1]->in==-1)
        {
            name2Duration[a[i]->id]+=a[i+1]->time-a[i]->time;
            stamps[a[i]->time]+=a[i]->in;
            stamps[a[i+1]->time]+=a[i+1]->in;
            ++i;
        }
    }
}
int main()
{
    int N,K;
    cin>>N>>K;
    string name,timeD,flag;
    int time,in;
    actList.resize(N);
    actListP.resize(N);
    for(int i=0;i<N;++i)
    {
        cin>>actList[i].id>>timeD>>flag;
        actList[i].time=time2Int(timeD);
        if(flag=="in")
            actList[i].in=1;
        else
            actList[i].in=-1;
        actListP[i]=&actList[i];    
    }
    sort(actListP.begin(),actListP.end(),cmp);
    filterAndFill(actListP);
    for(int i=1;i<day;++i)
        stamps[i]=stamps[i]+stamps[i-1];
    string stamp;
    int stampInt;
    for(int i=0;i<K;++i)
    {
        cin>>stamp;
        stampInt=time2Int(stamp);
        cout<<stamps[stampInt]<<endl;
    }
    int max=0;
    vector<string> result(0);
    for(pointDuration=name2Duration.begin();pointDuration!=name2Duration.end();++pointDuration)
        if(pointDuration->second>max)
            max=pointDuration->second;
    for(pointDuration=name2Duration.begin();pointDuration!=name2Duration.end();++pointDuration)
        if(pointDuration->second==max)
            result.push_back(pointDuration->first);
    if(int(result.size())>0)
    {
        sort(result.begin(),result.end());
        cout<<result[0]<<" ";
        for(int i=1;i<int(result.size());++i)
            cout<<result[i]<<" ";
        printf("%02d:%02d:%02d\n",max/3600,(max%3600)/60,max%60);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值