solution of POJ:2393.Yogurt factory

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky’s factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt’s warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky’s demand for that week.

Input

Line 1: Two space-separated integers, N and S.

Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.
Output

Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900


结题思路
题意要求我们给出最省钱的酸奶生产策略。
要求1:给出当天的生产价格和当天的酸奶需求量,我们可以选择接受当天的价格或者接受之前的价格并进行储藏
要求2:如果当天的价格大于之前的生产价格加上储藏价格的和,很明显,此时选择储藏可以带来更大的收益。

程序步骤
第一步、读入数据,判断若当前的生产价格小于选择的生产价格加上储藏的价格,更新选择的价格。
第二步、对每天的酸奶数据进行累加,题目提示int表示的32位数会出出现一出,选择long long。

具体程序(AC)如下

#include <iostream>
#include <cmath>
using namespace std;

int main() {
    // your code goes here
    int n, s;
    long long sum = 0;
    cin>>n >>s;
    int price = 5000;
    int priceNew, count;
    for(int i = 0; i < n; ++i)
    {
        cin>>priceNew >>count;
        price = min(price + s, priceNew);
        sum += price*count;
    }
    cout<<sum<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值