hdu 3826 Hand in Hand 同构图★

Hand in Hand

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 122768/62768 K (Java/Others)
Total Submission(s): 2402    Accepted Submission(s): 821


Problem Description
In order to get rid of Conan, Kaitou KID disguises himself as a teacher in the kindergarten. He knows kids love games and works out a new game called "hand in hand". 

Initially kids run on the playground randomly. When Kid says "stop", kids catch others' hands immediately. One hand can catch any other hand randomly. It's weird to have more than two hands get together so one hand grabs at most one other hand. After kids stop moving they form a graph.

Everybody takes a look at the graph and repeat the above steps again to form another graph. Now Kid has a question for his kids: "Are the two graph isomorphism?" 
 

Input
The first line contains a single positive integer T( T <= 100 ), indicating the number of datasets.
There are two graphs in each case, for each graph:
first line contains N( 1 <= N <= 10^4 ) and M indicating the number of kids and connections.
the next M lines each have two integers u and v indicating kid u and v are "hand in hand".
You can assume each kid only has two hands.
 

Output
For each test case: output the case number as shown and "YES" if the two graph are isomorphism or "NO" otherwise.
 

Sample Input
  
  
2 3 2 1 2 2 3 3 2 3 2 2 1 3 3 1 2 2 3 3 1 3 1 1 2
 

Sample Output
  
  
Case #1: YES Case #2: NO
题目挺简单。。
细节太多。。
同构图 :
1。点和边的个数相等。。
2.点的入度相同
3.环相同,连通分量相同
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define MAXN 100003
using namespace std;

struct Graph
{
    int son;
    bool ring;
} a[100003],b[100003];

int pre1[100003],pre2[100003];
void init()
{
    for(int i=0; i<100002; i++)
    {
        pre1[i]=i;
        pre2[i]=i;
        a[i].son=1;
        b[i].son=1;
        a[i].ring=false;
        b[i].ring=false;
    }
}
int cmp(Graph a,Graph b)
{
    if(a.son==b.son)
        return a.ring<b.ring;
    return a.son<b.son;
}
int Find(int x, int pre[]) //查找根结点+路径压缩
{
    return x == pre[x] ? x : pre[x]=Find(pre[x], pre);
}

void Merge(int x,int y,int pre[],Graph tmp[])
{
    int X=Find(x,pre);
    int Y=Find(y,pre);
    if(X==Y)
        tmp[X].ring=true;
    else
    {
        if(tmp[X].son>=tmp[Y].son)
            pre[Y]=X,tmp[X].son+=tmp[Y].son;
        else
            pre[X]=Y,tmp[Y].son+=tmp[X].son;
    }
}
bool judge(int num,Graph a[],Graph b[])
{
    sort(a+1,a+num+1,cmp);
    sort(b+1,b+num+1,cmp);
    for(int i=1;i<=num;i++)
    {
        if(a[i].son!=b[i].son||a[i].ring!=b[i].ring)
            return false;
    }
    return true;
}
int main()
{
    int iCase=0,T;
    scanf("%d",&T);
    while(T--)
    {
        int flag=true;
        init();
        int num1,match1,num2,match2;
        scanf("%d%d",&num1,&match1);

        
        for(int i=1;i<=match1;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            Merge(x,y,pre1,a);
        }
        scanf("%d%d",&num2,&match2);
        if(match1!=match2)
            flag=false;
        for(int i=1;i<=match2;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(flag) Merge(x,y,pre2,b);
        }
        if(flag)
        {
            flag=judge(num2,a,b);
             if(flag)
                printf("Case #%d: YES\n", ++iCase);
            else
                printf("Case #%d: NO\n", ++iCase);
        }
        else  printf("Case #%d: NO\n", ++iCase);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值