hdu 1513 Palindrome (滚动数组处理回文串)

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6433    Accepted Submission(s): 2127


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
  
  
5 Ab3bd
 

Sample Output
  
  
2
 

Source
 

Recommend
linle


将字符串反转存储在新的字符串中。
两个字符串求最长公共子序列。。
然后len- LCM 就是可进行的最少操作数。

因为5000^2的数组爆内存,而且每次的操作只和上一行有关所以就可以滚动数组。
具体操作看代码。



#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char M[5003];
char S[5003];
int dp[2][5003];
int main()
{
    int len;
    while(~scanf("%d",&len))
    {
        scanf("%s",M+1);
       // printf("---%s\n",M+1);
        for(int i=1;i<=len;i++)
        {
            S[len-i+1]=M[i];
        }
       // printf("---%s\n",S+1);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=len;i++)
        {
            for(int j=1;j<=len;j++)
            {
                dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
                if(M[i]==S[j])
                {
                    dp[i%2][j]=max(dp[i%2][j],dp[(i-1)%2][j-1]+1);
                }
            }
        }
        printf("%d\n",len-dp[len%2][len]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值