dfs之油田问题

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1241

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46962    Accepted Submission(s): 27038


 

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

 

Sample Input

1 1 
* 
3 5 
*@*@* 
**@** 
*@*@* 
1 8 
@@****@* 
5 5 
****@ 
*@@*@ 
*@**@ 
@@@*@ 
@@**@ 
0 0

Sample Output

0 
1 
2 
2

 

题目大意:‘@’就是油,它的周围(上下左右斜着)如果也有‘@’出现,那么就是合成一块大油田,要求总共有多少块大油田。

思路:一个一个搜索,dfs就行,模板题。

ac代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char map[110][110];
int vis[110][110];
int m,n;

void dfs(int x,int y,int sum){
	if(x<0||y<0||x>=m||y>=n){
		return;
	}
	if(map[x][y]!='@')return;
	map[x][y]='*';
	for(int dx=-1;dx<=1;dx++){
		for(int dy=-1;dy<=1;dy++){
			if(dx!=0||dy!=0)
			dfs(x+dx,y+dy,sum);
		}
	}
}
int main(){
	while(scanf("%d%d",&m,&n)&&m&&n){
		for(int i = 0; i < m; i ++)
        {
            getchar();
            for(int j = 0; j < n; j ++)
            {
                scanf("%c",&map[i][j]);
            }
        }

		memset(vis,0,sizeof(vis));
		int sum=0;
		for(int i=0;i<m;i++){
			for(int j=0;j<n;j++){
				if(map[i][j]=='@')
				dfs(i,j,++sum);
			}
		}
		cout<<sum<<endl;
	}
	return 0;
}

 

好的,让我来为您讲解如何使用DFS算法来解决迷宫问题DFS算法是一种搜索算法,它通过深度优先遍历图或树来寻找目标节点。在迷宫问题中,我们可以将每一个可行的位置看做是图中的一个节点,然后使用DFS算法来搜索从起点到终点的路径。 具体的实现步骤如下: 1. 定义一个二维数组来表示迷宫,其中0表示可以通过的通道,1表示障碍物。 2. 定义一个visited数组来记录每个节点是否被访问过。 3. 定义一个栈来保存搜索过程中经过的节点。 4. 从起点开始,将其加入栈中,并标记为已经访问。 5. 对于栈中的每个节点,依次遍历其相邻节点,如果相邻节点未被访问过且可以通过,则将其加入栈中,并标记为已经访问。 6. 如果最终找到了终点,搜索结束,返回路径;否则,回溯到上一个节点,继续搜索直到找到终点或者栈为空。 7. 如果栈为空,表示没有找到从起点到终点的路径。 下面是一个简单的实现示例代码: ```python def dfs(maze, visited, path, start, end): if start == end: return path + [end] visited[start[0]][start[1]] = True for dx, dy in [(1, 0), (-1, 0), (0, 1), (0, -1)]: x, y = start[0] + dx, start[1] + dy if 0 <= x < len(maze) and 0 <= y < len(maze[0]) and not visited[x][y] and maze[x][y] == 0: res = dfs(maze, visited, path + [start], (x, y), end) if res: return res return None # 测试代码 maze = [[0, 1, 0, 0, 0], [0, 1, 0, 1, 0], [0, 0, 0, 0, 0], [0, 1, 1, 1, 0], [0, 0, 0, 1, 0]] visited = [[False] * len(maze[0]) for _ in range(len(maze))] path = [] start = (0, 0) end = (4, 4) res = dfs(maze, visited, path, start, end) if res: print(res) else: print("找不到路径!") ``` 希望这个回答可以帮助您解决迷宫问题
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值