hdu1068 Ignatius's puzzle

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8929    Accepted Submission(s): 6204


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
  
  
11 100 9999
 

Sample Output
  
  
22 no 43

用数学归纳法做。

f(x) = 5*x^13 + 13*x^5 + k*a*x

f(x + 1) - f(x) = 5*x^13 + 13*x^5 + k*a*x + 65*(x^12 + x^11 + ..... + x) + 65*(x^5 + x^4 + ..... + x) + 18 + k*a.

所以是否能整除65由18 + k*a决定。


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    int k;
    while (~scanf("%d", &k))
    {
        int ans = -1;
        for (int i = 0; i < 66; ++i)
        {
            if ((k * i + 18) % 65 == 0)
            {
                ans = i;
                break;
            }
        }
        if (ans != -1)
            printf("%d\n", ans);
        else
            printf("no\n");
    }
    return 0;
}

有小伙伴不明白为什么为什么0 <= a < 66

嗯。

(18 + k*a) % 65 = (18 % 65) + (k * a) % 65 = 18 + (k % 65) * (a % 65)

所以、a超过65是没有意义的





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值