hdu 1098 Ignatius's puzzle

题目:
Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5x13+13*x5+ka*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print “no”.

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output
The output contains a string “no”,if you can’t find a,or you should output a line contains the a.More details in the Sample Output.

Sample Input
11
100
9999

Sample Output
22
no
43

题意:给定一个方程式f(x)=5x13+13*x5+kax,给定一个非负整数k,求能不能找到一个尽量小的非负整数a,使得上述方程式中的x任意取值,结果都能被65整除,如果有,输出a的值,否则输出no。
数学题:F(0)=0,能被65整除。f(1) = 18+ka,要是让f(1)也满足题目要求的条件,则18+6ka就能被65整除
假设18+6ka=i, a = (i
65-18)/k;利用循环,带入不同的i来求a。

代码:

//
//  main.cpp
//  hdu1098
//
//  Created by zhan_even on 2018/10/31.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
using namespace std;

int main(int argc, const char * argv[]) {
    int k,a;
    while (cin>>k) {
        a = 0;
        for(int i=1;i<10000;i++){
            if ((i*65-18)%k == 0) {
                a = (i*65-18)/k;
                break;
            }
        }
        if (a==0) {
            cout<<"no"<<endl;
        }
        else
            cout<<a<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值