Space Elevator poj 2392(多重背包)

问题描述

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000).

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

输入

* Line 1: A single integer, K

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

输出

* Line 1: A single integer H, the maximum height of a tower that can be built

样例输入

3
7 40 3
5 23 8
2 52 6

样例输出

48


先按照ai的大小排序然后就是完全背包了。
代码如下:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

int dp[40002];int sum[40002];
struct node
{
    int h,c,a;
}no[402];

bool operator<(node a,node b)
{
    return a.a<b.a;
}

int main()
{
    int n;
    scanf("%d",&n);
    int maxx=0;
    for(int i=1;i<=n;i++)
    {
        scanf("%d %d %d",&no[i].h,&no[i].a,&no[i].c);
        maxx=max(maxx,no[i].a);
    }
    sort(no+1,no+n+1);
    int ans=0;
     for(int i=1;i<=n;i++)
        {
            dp[0]=1;
            memset(sum,0,sizeof(sum));
            for(int j=no[i].h;j<=no[i].a;j++)
                if(!dp[j]&&dp[j-no[i].h]&&sum[j-no[i].h]<no[i].c)
            {
                dp[j]=1;
                sum[j]=sum[j-no[i].h]+1;
                ans=max(ans,j);
            }
        }
        printf("%d\n",ans);
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值