Six Degrees of Cowvin Bacon poj 2131(floyd)

问题描述

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.

输入

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.

输出

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

样例输入

4 2
3 1 2 3
2 3 4

样例输出

100


#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
using namespace std;

const int INF=999999999;
int ma[302][302];

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
    for(int i=0;i<=n;i++)
        for(int j=0;j<=n;j++)
            ma[i][j]=INF;
    
        for(int i=1;i<=m;i++)
        {
            int k;
            scanf("%d",&k);
            int tem[302];
            for(int j=1;j<=k;j++)
            {
                scanf("%d",&tem[j]);
            }
            for(int j=1;j<=k;j++)
                for(int l=j+1;l<=k;l++)
                ma[tem[j]][tem[l]]=ma[tem[l]][tem[j]]=1;
        }
        
        
        for(int k=1;k<=n;k++)
            for(int j=1;j<=n;j++)
                for(int i=1;i<=n;i++)
                ma[i][j]=min(ma[i][k]+ma[j][k],ma[i][j]);
                
                
        int ans=INF;
        for(int i=1;i<=n;i++)
        {
            int ans1=0;
            for(int j=1;j<=n;j++)
            {
                if(i!=j)
                {
                    ans1+=ma[i][j];
                }
            }
            ans=min(ans,ans1);
        }
        printf("%d\n",ans*100/(n-1));


    }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值