杭电oj 1005

先看题目

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 136694    Accepted Submission(s): 33137


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 


Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 


Output
For each test case, print the value of f(n) on a single line.
 


Sample Input
  
  
1 1 3 1 2 10 0 0 0
 


Sample Output
  
  
2 5
 
暴力计算肯定是会超时的,考虑到mod7运算肯定是会有循环的,循环结束的条件就是找到连续的两个数mod7相等,举个例子
若  f(a)%7=1,f(a+1)%7=2;  f(b)%7=1,f(b+1)%7=2;则循环的长度就是b-a,相信大家都能理解这个道理
但是有一点是它可能循环的时候并不是以f(1)开始的,所以我们不能以f(1)%7=1,f(2)%7=1来找循环结束条件
我得代码如下,
#include <iostream>
using namespace std;
int turn[1000];
int main()
{
	int A,B,number;
	int count;
	int i;
	bool flag;
	int start;
	cin>>A>>B>>number;
	turn[0]=1;
	turn[1]=1;
	while(A!=0||B!=0||number!=0)
	{
		count=3;
		turn[2]=(A*turn[1]+B*turn[0])%7;
		flag=false;
		while(1)
		{
			turn[count]=(A*turn[count-1]+B*turn[count-2])%7;
			for(i=0;i<count-2;i++)
			{
				if(turn[count-1]==turn[i]&&turn[count]==turn[i+1])
				{
					count=count-i;
					start=i;
					flag=true;
					break;
				}
			}
			if(flag==true)
				break;
			count++;	
		}
		if(number>start)
			cout<<turn[(number-start-1)%(count-1)+start]<<endl;
		else
			cout<<turn[number]<<endl;
				
		cin>>A>>B>>number;	
	}	
	return 0;
}
ac了


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值