2018.2.7 添加v7:27.+依赖库:Error:Failed to resolve: com.android.support:appcompat-v7:27.+

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_31344665/article/details/79283979
第三章的recyclerViewTest项目

要使用RecylerView这个控件,要先在项目的build.gradle中添加相应的依赖库才行。如下:

compile 'com.android.support:recyclerview-v7:26.+'(或其它版本v7:XXX)

不知道为什么,gradle会报错,而且之前可以运行的项目也有了bug:


临时解决办法:

修改app下的build.gradle文件如下:

把所有AS默认生成的27改成26,但buildToolsVersion保持27不变,因为高版本的buildTools可以用来构建低版本的项目,而且改成26会提示报错,应该是没有安装?
//noinspection GradleCompatible
apply plugin: 'com.android.application'

android {
    compileSdkVersion 26
    buildToolsVersion "27.0.3"
    defaultConfig {
        applicationId "com.example.recyclerviewtest"
        minSdkVersion 15
        targetSdkVersion 26
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        repositories {
            maven {
                url "https://maven.google.com"
            }
        }
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    compile 'com.android.support:appcompat-v7:26.+'
    compile 'com.android.support:recyclerview-v7:26.+'
    testCompile 'junit:junit:4.12'
}

终极解决办法:

参考stackoverflow,在最外层的project build.gradle中,修改如下:

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}

展开阅读全文

没有更多推荐了,返回首页