ZOJ Problem Set - 3640

Help Me Escape

Time Limit: 2 Seconds      Memory Limit: 32768 KB

    If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him.
    And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him.
    And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother's keeper?
    And he said, What hast thou done? the voice of thy brother's blood crieth unto me from the ground.
    And now art thou cursed from the earth, which hath opened her mouth to receive thy brother's blood from thy hand;
    When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

—— Bible Chapter 4

Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD's punishment, all the paths are zigzag and dangerous. The difficulty of the ith path is ci.

Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the N paths randomly.

Suppose Cain is in front of the ith path. He can successfully take ti days to escape from the cave as long as his fighting capacity f is larger than ci. Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase ci as the result of actual combat. (A kindly reminder: Cain will never died.)

As for ti, we can easily draw a conclusion that ti is closely related to ci. Let's use the following function to describe their relationship:

After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases.In each case, two positive integers N and f (n ≤ 100, f ≤ 10000) are given in the first line. The second line includes N positive integers ci (ci ≤ 10000, 1 ≤ i ≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input
3 1
1 2 3
Sample Output
6.889


题目的大概意思是一只吸血鬼每次随机的选择n个洞中的任意一个,如果该吸血鬼的攻击值大于该洞ci那么直接可以花费Ti的时间就可以出去
,不然要奋斗一天该吸血鬼攻击值增加ci再 随机选择n个洞.
设dp[i]表示攻击力为i时逃跑的期望。

 
//dp[i]标识逃出去的几率
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
using namespace std;
const int N = 20050;
double dp[N];
int c[150];
int t[150];
int main()
{
	int n, f;
	//freopen("in.txt", "r", stdin);
	while (~scanf("%d%d", &n, &f))
	{
		memset(dp, 0, sizeof(dp));
		int maxn = -1;
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &c[i]);
			t[i] = (double(1 + sqrt(double(5))) / 2) * c[i] * c[i];
			maxn = max(maxn, c[i] + 1);
		}
		for (int i = 1; i <= n; i++)
		{
			dp[maxn] += t[i];
		}
		dp[maxn] /= n;
		for (int i = N - 1; i > maxn; i--)
		{
			dp[i] = dp[maxn];
		}
		for (int i = maxn - 1; i >= f; i--)
		{
			for (int j = 1; j <= n; j++)
			{
				if (i > c[j])
				{
					dp[i] += t[j];
				}
				else
				{
					dp[i] +=1 + dp[i + c[j]];
				}
			}
			dp[i] /= n;
		}
		printf("%.3lf\n", dp[f]);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值