PAT 1002. A+B for Polynomials (25) c++版

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
题目意思:分两行给出两个多项式,输入的格式为:多项式的项数,指数,系数,指数,系数...求出这两个多项式相加后的项数,指数,系数
思路:用一个数组来存放多项式,数组下标为指数,数组中存放系数,将数组初始化为0,在接收输入时,直接将系数加到对应位置的数上.
注意:	1、输出的格式中,系数取到小数点后一位
	2、如果多项数相加后,所有项相加的和都为0,应输出一个0
#include <bits/stdc++.h>
using namespace std;

double temp[1005] = {0};

int main() {
	int k;
	for (int j = 0; j < 2; j++) {	//循环2次,读取两行的数据
		scanf("%d", &k);			//读取该行的项数
		for (int i = 0; i < k; i++) {
			int num;
			double t;
			scanf("%d %lf", &num, &t);		//读取每一项的系数和指数
			temp[num] += t;				//将指数作为数组的下标,对应的数组中存放系数的和
		}
	}
	int count = 0;
	//遍历查找多项式的项数
	for (int i = 0; i < 1001; i++)
		if (temp[i] != 0) count++;
	printf("%d", count);
	//按照指数从大到小的顺序输出指数和系数
	for (int i = 1000; i >= 0; i--)
		if (temp[i] != 0) printf(" %d %.1f", i, temp[i]);
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值