hdu 1213 并查集

原题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1213

Problem Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

题目大意:今天是Ignatius的生日,他想邀请朋友来参加他 的聚会,要求认识的朋友坐一桌,问最少需要几桌。
也就是求:有几个根节点。
一个重要的RULE:A认识B,B认识C,那么就说ABC互相认识。

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

查找根节点函数:
1.

int Find(int x)
{
    if(x!=father[x])
        father[x]=Find(father[x]);
    return father[x];
}

2.

int findRoot(int x)
{
    if (father[x] == x)
        return x;
    else
        return findRoot(father[x]);
}

3.

int findroot2(int x)
{
    int root = x;
    while(root != father[root])
        root = father[root];
    while(x!=root)
    {
        int tmp = father[x];
        father[x]=root;
        x = tmp;
    }
    return root;
}

前两种方法用递归实现,第三种未使用递归
下面是代码

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<cmath>
#include<iomanip>
#include<vector>
using namespace std;

int father[1010];

void makeSet()                 //初始化
{
    for(int i=0;i<1010;i++)
        father[i] = i;
    return;
}

int findroot(int x)          //找到根节点
{
    int root = x;
    while(root != father[root])
        root = father[root];
    while(x!=root)
    {
        int tmp = father[x];
        father[x]=root;
        x = tmp;
    }
    return root;
}

void Union(int x,int y)          //合并x,y为一个集合
{
    int xRoot,yRoot;
    xRoot = findroot(x);
    yRoot = findroot(y);
    father[xRoot]=yRoot;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int m,n,a,b;
        makeSet();
        scanf("%d %d",&m,&n);
        for(int i=0;i<n;i++){
            scanf("%d %d",&a,&b);
            Union(b,a);
        }
        int ans = 0;
        for(int i=1;i<=m;i++)
        {
            if(i==father[i]) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值