hdu1108 1061 gcd 快速幂

欧几里得算法:

int gcd(int max,int min) 
{ int temp; 
   while (min!=0) 
   { 
       temp=max%min; 
       max=min; 
       min=temp; 
    } 
    return(max);
} 

快速幂:

typedef long long LL;  
LL fun(LL x,LL n,LL Max)  
{  
    LL res=1;  
    while(n>0)  
    {  
        if(n & 1)  
            res=(res*x)%Max;  
        x=(x*x)%Max;  
        n >>= 1;  
    }  
    return res;  
} 

hdu 1061 Rightmost Digit
http://acm.hdu.edu.cn/showproblem.php?pid=1061

Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

#include <iostream>
#include <cstdio>
typedef long long LL;

using namespace std;

LL fun(LL x,LL n,LL Max)
{
    LL res=1;
    while(n>0)
    {
        if(n & 1)
            res=(res*x)%Max;
        x=(x*x)%Max;
        n >>= 1;
    }
    return res;
}

int main()
{
    int t;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            LL n;
            scanf("%lld",&n);
            printf("%lld\n",fun(n,n,10));
        }
    }
    return 0;
}

hdu 1108 最小公倍数
http://acm.hdu.edu.cn/showproblem.php?pid=1108

Problem Description
给定两个正整数,计算这两个数的最小公倍数。

Input
输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.

Output
对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。

Sample Input
10 14

Sample Output
70

#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
using namespace std;
int gcd(int big,int sma);
int main()
{
    int a,b,c,d;
    while(scanf("%d %d",&a,&b)!=EOF)
    {
        if(a<b)  {c=a;a=b;b=c;}
        d = (a*b)/gcd(a,b);
        printf("%d\n",d);
    }
    return 0;
}
int gcd(int big,int sma)
{
    int t;
    while(sma!=0){
        t=big%sma;
        big = sma;
        sma = t;
    }return big;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值