HDU 1863 畅通工程 Kruskal算法

题目的链接如下:
http://acm.hdu.edu.cn/showproblem.php?pid=1863

畅通工程

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25872 Accepted Submission(s): 11274

Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。

Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。

Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。

Sample Input
3 3
1 2 1
1 3 2
2 3 4
1 3
2 3 2
0 100

Sample Output
3
?

include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 100 + 10;
int father[maxn];
int n,m;
struct node{
    int v1,v2,len;
    node(int v1 = 0,int v2 = 0,int len = 0):v1(v1),v2(v2),len(len){}
}no[maxn];
bool cmp(node a,node b){
    return a.len < b.len;
}
void makeSet(int n){
    for(int i=0;i<=n;i++) father[i] = i;
}
int Find(int x){ //递归版本
    if(x == father[x]) return x;
    return father[x] = Find(father[x]);
}
int Find2(int x){//迭代版本
    int tempRoot;
    int root = x;
    while(root != father[root]) //找到根节点。
        root = father[root];
    while(x != root){
        tempRoot = father[x]; //x的父节点用临时变量存一下。
        father[x] = root; //x的父节点设置成根 (x 压缩到根节点了)
        x = tempRoot;   //x 赋值为 x的父节点(之前存过的);
    }
    return root; // 最后返回根节点
}
void Union(int x,int y){
    int xroot = Find(x);
    int yroot = Find(y);
    if(xroot != yroot){
        father[xroot] = yroot;
    }
}
void KrusKal(){
    sort(no,no+n,cmp);
    int edge = 0;
    int ans = 0;
    for(int i=0;i<n;i++){ // n-1条边
        if(Find(no[i].v1) != Find(no[i].v2)){
            ans += no[i].len;
            Union(no[i].v1,no[i].v2);
            edge++;
        }
    }
    if(edge == m-1) printf("%d\n",ans); // m是顶点个数
    else
        printf("?\n");
}
int main(){
    while(scanf("%d",&n)!=EOF && n){
        scanf("%d",&m);
        makeSet(m);
        for(int i=0;i<n;i++){
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            no[i] = node(a,b,c);
        }
        KrusKal();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值