POJ 2624 4th Point 计算几何(向量)

题目的链接如下:http://poj.org/problem?id=2624

4th Point
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5057 Accepted: 1760

Description
Given are the (x,y) coordinates of the endpoints of two adjacent sides of a parallelogram. Find the (x,y) coordinates of the fourth point.

Input
Each line of input contains eight floating point numbers: the (x,y) coordinates of one of the endpoints of the first side followed by the (x,y) coordinates of the other endpoint of the first side, followed by the (x,y) coordinates of one of the endpoints of the second side followed by the (x,y) coordinates of the other endpoint of the second side. All coordinates are in meters, to the nearest mm. All coordinates are between -10000 and +10000.

Output
For each line of input, print the (x,y) coordinates of the fourth point of the parallelogram in meters, to the nearest mm, separated by a single space.

Sample Input

0.000 0.000 0.000 1.000 0.000 1.000 1.000 1.000
1.000 0.000 3.500 3.500 3.500 3.500 0.000 1.000
1.866 0.000 3.127 3.543 3.127 3.543 1.412 3.145

Sample Output

1.000 0.000
-2.500 -2.500
0.151 -0.398

题目的大意如下:给你三个点ABC (我假设输入中给出的相同的那个点是点A)让你求平行四边形的第四个点D(注意这里的三个点不一定就是第二个点和第三个点相同),然后用向量做的话:AB + AC = AD 所以D点的坐标就是B+C-A的坐标,具体的代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#define eps 1e-8
struct TPoint
{
    double x,y;
     TPoint operator-(TPoint&a){
         TPoint p1;
        p1.x=x-a.x;
        p1.y=y-a.y;
        return p1;
    }
};
using namespace std;
int main() {
    TPoint ans;
    TPoint a[10];
    while(~scanf("%lf%lf", &a[0].x, &a[0].y)) {
        ans.x = a[0].x, ans.y = a[0].y;
        int flag = 1, t = 0;
        for(int i = 1; i < 4; i++) {
            scanf("%lf%lf", &a[i].x, &a[i].y);
            ans.x += a[i].x;
            ans.y += a[i].y;
            for(int j = 0 ; flag && j < i; j++){
                if(a[i].x == a[j].x && a[i].y == a[j].y){
                    flag = 0;
                    t = i;
                }
            }
        }
        ans.x -= 3 * a[t].x;
        ans.y -= 3 * a[t].y;
        printf("%.3f %.3f\n", ans.x, ans.y);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值