POJ-2624 4th Point(计算几何)

4th Point
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4943 Accepted: 1735

Description

Given are the (x,y) coordinates of the endpoints of two adjacent sides of a parallelogram. Find the (x,y) coordinates of the fourth point.

Input

Each line of input contains eight floating point numbers: the (x,y) coordinates of one of the endpoints of the first side followed by the (x,y) coordinates of the other endpoint of the first side, followed by the (x,y) coordinates of one of the endpoints of the second side followed by the (x,y) coordinates of the other endpoint of the second side. All coordinates are in meters, to the nearest mm. All coordinates are between -10000 and +10000.

Output

For each line of input, print the (x,y) coordinates of the fourth point of the parallelogram in meters, to the nearest mm, separated by a single space.

Sample Input

0.000 0.000 0.000 1.000 0.000 1.000 1.000 1.000
1.000 0.000 3.500 3.500 3.500 3.500 0.000 1.000
1.866 0.000 3.127 3.543 3.127 3.543 1.412 3.145

Sample Output

1.000 0.000
-2.500 -2.500
0.151 -0.398


我勒个fuck,这个貌似也是调了好久,要赶紧将状态提上来啊

题意:已知平行四边形的两条邻边,求第四个点的坐标

思路:相同的那个点为基础点(自己定义的),用其他两个点与其形成两个向量,加和即平行四边形对角线向量,再加基础点就ok了。。点+向量=点按照向量的方向  延长  向量的模  的长度

就像这个,B+BD向量=D

#include <iostream>
#include<cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const double EPS = 1e-6;
struct Point
{
    double x,y;
    Point(){};
    Point(double a,double b){
        x=a;y=b;
    }
};
Point operator - (const Point a,const Point b)
{
        return Point(a.x-b.x,a.y-b.y);
}

Point operator + (const Point a,const Point b)
{
       return Point(a.x+b.x,a.y+b.y);
}
int sgn(double d)
{
  return (d>+EPS)-(d<-EPS);
}


int iszero(Point a,Point b)
{
    if (sgn(a.x-b.x)==0&&sgn(a.y-b.y)==0) return 1;
    else return 0;
}
Point p,q,r,s,t;
int main()
{//p,r,t,q
    while(~scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&p.x,&p.y,&r.x,&r.y,&t.x,&t.y,&q.x,&q.y))
    {
        if(iszero(p,t))
            s = p + r - p + q -t;
        if(iszero(p,q))
            s = p + r - p + t - q;
        if(iszero(r,t))
            s = r + p - r + q - t;
        if(iszero(r,q))
            s = r + p - r + t - q;
        printf("%.3f %.3f\n",s.x,s.y);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值