poj 1308 Is It A Tree?并查集

题目的链接如下:点击打开链接


Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 30347 Accepted: 10332

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source





#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

//首先我们解释一下题意,他给你一个有向图,然后让你判断这个图是不是树
//我们来说一下树的概念,然后模拟一下就行了,首先什么叫做树呢
//有且只有一个根节点,根节点的入度为零,然后其余的每个节点,他们的入度都是一,这就是我们最骚的东西了。
//也就是说只有一个的父节点就是他,所以为什么我们能够用到并查集就是这个原因了,
//然后这个题的节点数目不是从零开始的,是随机的,所以为了方便,我们用一个vis[]数组,如果有这个节点那么
//我们就把它标记为1,然后把他们加入树中,然后用一个maxx存最大的节点名字,因为我们不知道有多少个节点,
//所以我们把最大的记下来,然后用for循环找,每个vis[i]==1的点就是有的点,然后再判断是不是只有一个根节点即可
//判断根节点就是根据cnt来判断,如果father[i]==i,就让cnt++,所以cnt==1的时候就是一个根节点。
//然后,这个题有个特殊的东西,空树也是树。。很尴尬,所以当cnt == 0 的时候也是树,基本就这些。

const int maxn = 10000 + 50;
int father[maxn];
int vis[maxn];
int maxx;
int flag;

using namespace std;
void init()
{
	for(int i = 0 ; i <= maxn ; i++)
		father[i] = i;
    memset(vis, 0, sizeof(vis));
    flag = 1;
    maxx = 0;
}

int find(int x)
{
	if(father[x] != x)
		 father[x]=find(father[x]);
	return father[x];
}

void Union(int x, int y)
{
	int xroot = find(x);
	int yroot = find(y);
    if(y!=yroot||xroot==yroot)
        flag=0;
	if(xroot != yroot)
		father[yroot] = xroot;//y的父亲是x

}

int main()
{
    int Case = 0;
    int u, v;
    init();
    while(~scanf("%d%d",&u,&v)&&u>=0&&v>=0)
    {
        if(u == 0 && v == 0)
        {
            int cnt = 0;
            for(int i = 1 ; i <= maxx ; i++)
                if(vis[i] && i==father[i])
                    cnt++;
            if(cnt<=1 && flag)
                printf("Case %d is a tree.\n",++Case);
            else
                printf("Case %d is not a tree.\n",++Case);
            init();
            continue;
        }
        maxx=max(maxx,max(u,v));
        vis[u]=vis[v]=1;
        Union(u,v);
    }
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值