hdu 1051 && poj 1065 Wooden Sticks(贪心+动态规划——单调递增子序列)

题目链接如下:

点击打开链接               



Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit:

65536/32768 K (Java/Others)
Total Submission(s): 19376    Accepted Submission(s): 7890


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 

描述

C小加有一些木棒,它们的长度和质量都已经知道,需要一个机器处理这些木棒,机器开启的时候需要耗费一个单位的时间,如果第i+1个木棒的重量和长度都大于等于

 

第i个处理的木棒,那么将不会耗费时间,否则需要消耗一个单位的时间。因为急着去约会,C小加想在最短的时间内把木棒处理完,你能告诉他应该怎样做吗?

 

输入

第一行是一个整数T,表示输入数据一共有T组。

每组测试数据的第一行是一个整数N(1<=N<=5000),表示有N个木棒。接下来的一行分别输入N个木棒的L,W(0 < L ,W <= 10000),用一个空格隔开,分别表示

 

木棒的长度和质量。

 

输出

处理这些木棒的最短时间。

#include<iostream>  
#include<algorithm>  
#include<string.h>  
using namespace std;  
struct Machine  
{  
    int l, w;  
}data[5010];  
bool use[5010]; //标记木棒是否用过:1用过,0未用过  
bool operator < (const Machine a, const Machine b) //将木棒排序 长度递增 若相等则重量递增  
{  
    if(a.l == b.l)  
        return a.w < b.w;  
    return a.l < b.l;  
}  
int main()  
{  
//  freopen("1.txt","r",stdin);  
    int t;  
    cin>>t;  
    while(t--)  
    {  
        memset(use, 0, sizeof(use));  
        int n, count = 0;  
        Machine last;  
        cin>>n;  
        for(int i = 0; i < n; ++i)  
        {  
            cin>>data[i].l>>data[i].w;  
        }  
        sort(data, data + n); //木棒排序  
        for(int i = 0; i < n; ++i) //对第i个木棒 求递增子序列  
        {  
            last.w = data[i].w; //记录新序列的开始  
            if(!use[i])  
            {  
                for(int j = i + 1; j < n; j++)  
                {  
                    if(last.w <= data[j].w && !use[j]) //l已经排序 不需要比较  
                    {  
                        use[j] = 1; //用到则标记为1  
                        last.w = data[j].w; //队尾元素  
                    }  
                }  
                count++; //子序列结束后,时间加1.计算第i + 1个木棒  
            }  
        }  
        cout<<count<<endl;  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值