题目描述
试计算在区间 11 到 nn的所有整数中,数字x(0 ≤ x ≤ 9)x(0≤x≤9)共出现了多少次?例如,在 11到1111中,即在 1,2,3,4,5,6,7,8,9,10,111,2,3,4,5,6,7,8,9,10,11 中,数字 11 出现了 44 次。
输入输出格式
输入格式:
22个整数n,xn,x,之间用一个空格隔开。
输出格式:
11个整数,表示xx出现的次数。
输入输出样例
输入样例#1:
11 1
输出样例#1:
4
说明
对于 100\%100%的数据,1≤ n ≤ 1,000,000,0 ≤ x ≤ 91≤n≤1,000,000,0≤x≤9。
AC_CODE:
#include<bits/stdc++.h>
using namespace std;
int main()
{
long long n, i, x, b, c, t = 0; cin >> n >> x;
for ( i = 1; i <= n; ++i)
{
b = i;
while (b)
{
c = b % 10;
b /= 10;
if (c == x)
t++;
}
}
cout << t;
return 0;
}
AC_Perfect:
#include<iostream>
#include<cstdio>
using namespace std;
int main(){
int n,x,m=1,ans=0;
scanf("%d%d",&n,&x);
while(m<=n){
int a=n/(m*10),b=n/m%10,c=n%m; //a,b,c为n的三部分,求哪一位x的个数,b就为那一位数,a为b左边的数,c为b右边的数,如求1~728中十位7的个数,则a=7,b=2,c=8
if(x){
if(b>x) ans+=(a+1)*m; //如果b>x,说明有(a+1)*m个x(如求1~728中个位7的个数,则为(72+1)*1=73)
if(b==x) ans+=a*m+c+1; //如果b=x,说明有a*m+c+1个x(如求1~728中百位7的个数,则为0*100+28+1=29)
if(b<x) ans+=a*m; //如果b<x,说明有a*m个x(如求1~728中十位7的个数,则为7*10个)
}
else{ //x=0的情况和x!=0的情况有所不同
if(b) ans+=a*m;
else ans+=(a-1)*m+c+1;
}
m*=10;
}
printf("%d\n",ans);
return 0;
}