LightOJ-1117 Helping Cicada(容斥定理)

A - Helping Cicada
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Cicada is an insect with large transparent eyes and well-veined wings similar to the "jar flies". The insects are thought to have evolved 1.8 million years ago during the Pleistocene epoch. There are about 2,500 species of cicada around the world which live in temperate tropical climates.

These are all sucking insects, which pierce plants with their pointy mouthparts and suck out the juices. But there are some predators (like birds, the Cicada Killer Wasp) that attack cicadas. Each of the predators has a periodic cycle of attacking Cicadas. For example, birds attack them every three years; wasps attack them every 2 years. So, if Cicadas come in the 12th year, then birds or wasps can attack them. If they come out in the 7th year then no one will attack them.

So, at first they will choose a number N which represents possible life-time. Then there will be an integer M indicating the total number of predators. The next M integers represent the life-cycle of each predator. The numbers in the range from 1 to N which are not divisible by any of those M life-cycles numbers will be considered for cicada's safe-emerge year. And you want to help them.

Input

Input starts with an integer T (≤ 125), denoting the number of test cases.

Each case contains two integers N (1 ≤ N < 231) and M (1 ≤ M ≤ 15). The next line contains M positive integers (fits into 32 bit signed integer) denoting the life cycles of the predators.

Output

For each test case, print the case number and the number of safe-emerge days for cicada.

Sample Input

2

15 3

2 3 5

10 4

2 4 5 7

Sample Output

Case 1: 4

Case 2: 3

题意:Cicada有n种天敌,他们的活动周期分别是a[i],在天敌的活动日里面Cicada是不安全的,问在n天内有多少天Cicada是安全的

题解:容斥定理

#include<cstdio>
#include<string.h>
typedef long long LL;
int m;
LL a[25],n,ans;
LL gcd(LL a,LL b){return b?gcd(b,a%b):a;}
LL Lcm(LL a,LL b){return a/gcd(a,b)*b;}
void dfs(int cnt,LL lcm,int odd){
    lcm=Lcm(a[cnt],lcm);
    if(odd) ans-=n/lcm;
    else ans+=n/lcm;
    for(int i=cnt+1;i<m;i++) dfs(i,lcm,odd^1);
}
int main(){
    int T;
  //  freopen("in.txt","r",stdin);
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++){
        scanf("%lld%d",&n,&m);
        for(int i=0;i<m;i++) scanf("%lld",&a[i]);
        ans=n;
        for(int i=0;i<m;i++) dfs(i,1,1);
        printf("Case %d: %lld\n",cas,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值