HDU-1506 Largest Rectangle in a Histogram(单调栈)

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18789    Accepted Submission(s): 5623


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
      
      
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
      
      
8 4000

对于单调递增的单调栈:
插入第i个元素A[i]时,假设栈顶元素为第j个元素A[j](j<i)
①如果栈顶元素小于A[i]则弹出栈顶,直到栈顶元素小于A[i],并将栈顶元素的右边界扩展为i-1(A[i]是从j往右第一个小于A[j]的元素)
②如果栈顶元素大于A[i]直接插入A[i]
③假设栈顶元素为第j个元素,则第i个元素的左边界为j(A[j]是从i往左第一个小于A[i]的元素)

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int MX = 1e5 + 5;
LL a[MX];
int L[MX],R[MX];
int main(){
    int n;
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&n),n){
        stack<int>s;s.push(0);
        LL ans=0;
        for(int i=1;i<=n+1;i++){
            if(i<=n) scanf("%lld",&a[i]);
            else a[i]=0;
            L[i]=i;R[i]=i;
            while(s.size()>1&&a[s.top()]>=a[i]) {
                R[s.top()]=i-1;
                s.pop();
            }
            L[i]=s.top();
            s.push(i);
        }
        for(int i=1;i<=n;i++) ans=max(ans,(R[i]-L[i])*a[i]);
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值