HDU-6430 TeaTree(线段树合并)

Problem E. TeaTree

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 165    Accepted Submission(s): 57


 

Problem Description

Recently, TeaTree acquire new knoledge gcd (Greatest Common Divisor), now she want to test you.
As we know, TeaTree is a tree and her root is node 1, she have n nodes and n-1 edge, for each node i, it has it’s value v[i].
For every two nodes i and j (i is not equal to j), they will tell their Lowest Common Ancestors (LCA) a number : gcd(v[i],v[j]).
For each node, you have to calculate the max number that it heard. some definition:
In graph theory and computer science, the lowest common ancestor (LCA) of two nodes u and v in a tree is the lowest (deepest) node that has both u and v as descendants, where we define each node to be a descendant of itself.

Input

On the first line, there is a positive integer n, which describe the number of nodes.
Next line there are n-1 positive integers f[2] ,f[3], …, f[n], f[i] describe the father of node i on tree.
Next line there are n positive integers v[2] ,v[3], …, v[n], v[i] describe the value of node i.
n<=100000, f[i]<i, v[i]<=100000

Output

Your output should include n lines, for i-th line, output the max number that node i heard.
For the nodes who heard nothing, output -1.

Sample Input

4 1 1 3 4 1 6 9

Sample Output

2 -1 3 -1

Source

2018 Multi-University Training Contest 10

题意:一棵树上每个节点权值为v[i],每个节点的heard值是:以它为LCA的两个节点的GCD的最大值,要求输出每个节点的heard值

题解:线段树合并,对每个节点建一棵线段树,第x个位置就表示v[i]有值为x的因子,只要2个节点有相同的因子就维护答案,每次都把所有子节点的线段树与父节点合并。

#include<bits/stdc++.h>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define x first
#define y second
#define rep(i,a,b) for(int i=a;i<b;++i)
#define per(i,a,b) for(int i=a-1;i>=b;--i)
#define fuck(x) cout<<'['<<#x<<' '<<(x)<<']'
#define add(x,y) x=((x)+(y)>=mod)?(x)+(y)-mod:(x)+(y)
#define sub(x,y) x=((x)-(y)<0)?(x)-(y)+mod:(x)-(y)
#define eps 1e-10
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef vector<int> VI;
typedef pair<int, int> PII;
const int mod = 1e9 + 7;
const int INF = 0x3f3f3f3f;
const ll INFLL = 0x3f3f3f3f3f3f3f3fll;
const int MX = 1e5;
const int MXM = 400 * MX;
int v[MX + 5], nxt[MX + 5], head[MX + 5], tot;
void init(int n) {
    rep(i, 1, n + 1) head[i] = -1;
    tot = 0;
}
inline void edge_add(int u, int vv) {
    v[tot] = vv, nxt[tot] = head[u], head[u] = tot++;
}
int ans[MX + 5], n;
vector<int>ver[MX + 5];
void init() {
    rep(i, 1, MX + 1) ver[i].push_back(1);
    rep(i, 2, MX + 1) {
        ver[i].push_back(i);
        for(int j = i + i; j <= MX; j += i) ver[j].push_back(i);
    }
}
int root[MX + 5], ls[MXM], rs[MXM], sum[MXM], rear;
inline void PushUP(int rt) {
    if(ls[rt] && rs[rt]) sum[rt] = max(sum[ls[rt]], sum[rs[rt]]);
    else if(ls[rt]) sum[rt] = sum[ls[rt]];
    else if(rs[rt]) sum[rt] = sum[rs[rt]];
}
int merge(int rt, int prt, int& ans) {
    if(rt == 0 || prt == 0) return rt ^ prt;
    if(sum[rt] == sum[prt]) ans = max(ans, sum[rt]);
    if(ls[rt] | ls[prt]) ls[rt] = merge(ls[rt], ls[prt], ans);
    if(rs[rt] | rs[prt]) rs[rt] = merge(rs[rt], rs[prt], ans);
    PushUP(rt);
    return rt;
}
void dfs(int u) {
    ans[u] = -1;
    for(int i = head[u]; ~i; i = nxt[i]) {
        dfs(v[i]);
        root[u] = merge(root[u], root[v[i]], ans[u]);
    }
}
void update(int p, int l, int r, int &rt) {
    if(rt == 0) rt = ++rear;
    if(l == r) {
        sum[rt] = p;
        return;
    }
    int m = (l + r) >> 1;
    if(p <= m) update(p, l, m, ls[rt]);
    else update(p, m + 1, r, rs[rt]);
    PushUP(rt);
}
int main() {
#ifdef local
    freopen("in.txt", "r", stdin);
    freopen("out1.txt","w+",stdout);
#endif // local
    init();
    int x, fa;
    cin >> n;
    init(n);
    rep(i, 2, n + 1) {
        scanf("%d", &fa);
        edge_add(fa, i);
    }
    rear = 0;
    rep(i, 1, n + 1) {
        scanf("%d", &x);
        root[i] = 0;
        rep(j, 0, ver[x].size()) update(ver[x][j], 1, MX, root[i]);
    }
    dfs(1);
    rep(i, 1, n + 1) printf("%d\n", ans[i]);
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值