Frogger(最大生成树的最小权的最短路做法)

原题链接
Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38314 Accepted: 12335
Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
Source

Ulm Local 1997

//http://poj.org/problem?id=2253
//题目大意,有两只青蛙,分别在两个石头上,青蛙A想要到青蛙B那儿去,他可以直接跳到B的石头上,也可以跳到其他石头上,再从其他石头跳到B那儿,求青蛙从A到B的所有路径中最小的Frog Distance,我们定义Frog Distance为从A到B的一条路径中所跳的最大距离,例如,如果从A到B某条路径跳的距离是2,5,6,4,则Frog Distance就是6,题目输入的第一行代表石头的个数,当个数为0时结束程序,接着有n行,其中第2,3行分别代表A,B青蛙的坐标,其他n-2行分别代表空的石头的坐标,输出一个小数(保留三位),具体格式参见样例,注意没输出一个答案还要再空一行。
//题目数据1很明显为5.000
//对于数据2青蛙有两种方案
//方案1:1-2则经过距离为2.000故此时Frog Distance=2.000
//方案2:1-3-2 则经过距离分别是1.414 1.414 故此时Frog Distance=1.414
//故所求的最小的Frog Distance=1.414
//这个题和poj1797非常像,只是1797是求所有路径的最小值中的最大值,这个题是求所有路径中的最大值的最小值
#include <algorithm>
#include <iostream>
#include <utility>
#include <sstream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
using namespace std;

typedef long long ll;
const int MOD = int(1e9) + 7;
//int MOD = 99990001;
const int INF = 0x3f3f3f3f;
const ll INFF = 0x3f3f3f3f3f3f3f3fLL;
const double EPS = 1e-9;
const double OO = 1e20;
const double PI = acos(-1.0); //M_PI;
const int fx[] = {-1, 1, 0, 0};
const int fy[] = {0, 0, -1, 1};
const int maxn=200 + 5;//边最多就有这么多
struct node{int x,y;};
float cost[maxn][maxn];//从下标为i的结点到下标为j的结点的距离
node a[205];//定义了一些点
float d[205];//定义d[i][j]是从(startx,starty)到(i,j)的所有路径中的最大值的最小值
int n,kase=0;
float cal(int x1,int y1,int x2,int y2){
        if(x1<x2) swap(x1,x2);
        if(y1<y2) swap(y1,y2);
        return sqrt((x1-x2)*(x1-x2) + (y1-y2)*(y1-y2));
}
void Bellman_ford(){
        while(true){
                bool flag=false;
                for(int i=0;i<n;i++){
                        for(int j=0;j<n;j++){
                                if(d[j] > max(d[i],cost[i][j])) { d[j]=max(d[i],cost[i][j]);flag=true;}
                                if(d[i] > max(d[j],cost[j][i])) { d[i]=max(d[j],cost[j][i]);flag=true;}
                        }
                }
                if(!flag) break;
        }
        return;
}
int main(){
        while(scanf("%d",&n)==1 && n){
                memset(cost,0,sizeof(cost));
                memset(d,0,sizeof(d));
                cin >> a[0].x >> a[0].y;
                cin >> a[1].x >> a[1].y;//最后就是求float[1];
                d[1]=cal(a[0].x,a[0].y,a[1].x,a[1].y);
                for(int i=2;i<n;i++)
                        scanf("%d%d",&a[i].x,&a[i].y);
                for(int i=0;i<n;i++){
                        for(int j=0;j<n;j++){
                                if(i==j) cost[i][j]=0;
                                //这里由于所有的点都是相互可达的,所以需要所有的点都计算一下距离
                                else cost[i][j]=cal(a[i].x,a[i].y,a[j].x,a[j].y);
                        }
                }
                for(int i=0;i<n;i++)
                        d[i]=cost[0][i];
                Bellman_ford();
                printf("Scenario #%d\nFrog Distance = %.3f\n\n",++kase,d[1]);
        }
        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值