POJ3320-Jessica's Reading Problem【尺取法】

原题链接
Jessica’s Reading Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10854 Accepted: 3639
Description

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1
Sample Output

2
Source

POJ Monthly–2007.08.05, Jerry
题目的意思就是一本书的每一页都有一个知识点,知识点是散落的,主人公想通过阅读连续的一部分获得所有的知识点,求出最少的阅读页数

//http://poj.org/problem?id=3320
#include <algorithm>
#include <iostream>
#include <utility>
#include <sstream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
using namespace std;

typedef long long ll;
const int MOD = int(1e9) + 7;
//int MOD = 99990001;
const int INF = 0x3f3f3f3f;
const ll INFF = (~(0ULL)>>1);
const double EPS = 1e-9;
const double OO = 1e20;
const double PI = acos(-1.0); //M_PI;
const int fx[] = {-1, 1, 0, 0};
const int fy[] = {0, 0, -1, 1};
const int maxn=1000000 + 5;
int a[maxn];
void solve(int n){
        int res=n,sum=0,b=0,e=0;
        set<int> all;
        for(int i=0;i<n;i++)
                all.insert(a[i]);
        int len=all.size();
        map<int,int> Count;
        for(;;){
                while(e<n && sum < len){
                        if(Count[a[e]] == 0){
                                sum++;
                        }
                        Count[a[e]]++;
                        e++;
//                        if(Count[a[e++]]++ == 0){
//                                sum++;
//                        }
                }
                if(sum < len) break;
                res=min(res,e-b);
                Count[a[b]]--;
                if(Count[a[b]]==0){
                        sum--;
                }
                b++;
                //上面这个修改的代码顺序一点都变不得
//                if(--Count[a[b++]]==0){
//                        sum--;
//                }
        }
        printf("%d\n",res);

}
int main(){
        int n;
        cin >> n;
        for(int i=0;i<n;i++)
                scanf("%d",&a[i]);
        solve(n);
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值