POJ1065-Wooden Sticks-最长下降子序列

原题链接
Wooden Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22711 Accepted: 9731
Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l <= l’ and w <= w’. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,…, ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output

The output should contain the minimum setup time in minutes, one per line.
Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output

2
1
3
Source

Taejon 2001
思路:题目的确需要稍加思考,这道题的要求其实是将所有stick分为x个不下降子序列( Ai <= Ai+1 ),然后问题归结于求x的最小值。
x的最小值其实等于按l递增排序后stick按w最长下降子序列的长度L,证明如下:
若x < L,先从stick中取出最长下降子序列L,取走的元素留下一个大小相同的“空穴”,
然后将剩下的元素和空穴分成x个不下降子序列。接着把最长下降子序列L中的L个元素放回这L个空穴里。
由于x < L,所以根据鸽笼原理,必然有两个或两个以上的下降子序列L中的元素(b > a)被按顺序放到同一个不下降子序列(a <= b),
而这x个序列本应该是不下降的,这就产生了矛盾,所以x >= L,所以x的最小值就是L了。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 5000 + 10;
typedef struct sticks{
	int l,w;
}sticks;
sticks a[maxn];
int dp[maxn],n;//dp[i+1]:最长下降子序列第i位的数字大小
bool cmp(sticks x,sticks y){
	if(x.l < y.l) return true;
	else if(x.l==y.l) return x.w<y.w ? true : false;
	else return false;
}
//从一个递减序列中返回第一个>=x的数的下标
int serch(int x){
	int l=-1,r=maxn-1,mid;
	while(r-l>1){
		mid=(l+r)/2;
		if(dp[mid]>x) l=mid;
		else r=mid;
	}
	return r;
}
int main(){
	int T;
	cin >> T;
	while(T--){
		cin >> n;
		for(int i=0;i<n;i++) scanf("%d%d",&a[i].w,&a[i].l);
		sort(a,a+n,cmp);
		memset(dp,-1,sizeof(dp));
		for(int i=0;i<n;i++) dp[serch(a[i].w)] = a[i].w;
		cout << serch(-1) << endl;
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值