poj3278

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 71110 Accepted: 22371

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<malloc.h>
#include<math.h>
struct node{
    int step;
    int loc;
};
struct node que[1000005];
int book[400005];
int main(){
    int start,end;
    int head=0;
    int tail=0;
    scanf("%d %d",&start,&end);
    if(start>=end)
        printf("%d\n",start-end);
    else{
        que[tail].loc=start;
        que[tail].step=0;
        book[start]=1;
        tail++;
        int i,j;
        int t=0;
        int flag=0;
        while(head<tail){
            for(i=1;i<=3;i++){
                if(i==1){
                    t=que[head].loc-1;
                }
                else if(i==2){
                    t=que[head].loc+1;
                }
                else if(i==3){
                    t=que[head].loc*2;
                }
                if(t<0||t>100005)
                    continue;
                if(book[t]==0){
                    book[t]=1;
                    que[tail].loc=t;
                    que[tail].step=que[head].step+1;
                    tail++;
                }
                if(t==end){
                    flag=1;
                    break;
                }
            }
            if(flag)
                break;
            head++;
        }
        printf("%d\n",que[tail-1].step);
    }
    return 0;
}
注意考虑起点和终点一样的情况

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值