All in All
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 31712 | Accepted: 13155 |
Description
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence person compression VERDI vivaVittorioEmanueleReDiItalia caseDoesMatter CaseDoesMatter
Sample Output
Yes No Yes No
暴力解决,简单粗暴
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<malloc.h>
#include<math.h>
int main(){
char a[100005],b[100005];
while(~scanf("%s",a)){
scanf("%s",b);
int lena=strlen(a);
int lenb=strlen(b);
int i,j;
i=0;j=0;
while(1){
if(i==lena){
printf("Yes\n");
break;
}
else if(i<lena&&j==lenb){
printf("No\n");
break;
}
if(a[i]==b[j]){
i++;
j++;
}
else{
j++;
}
}
}
return 0;
}