poj2488

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40609 Accepted: 13800

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

1、  题目要求以"lexicographically"方式输出,也就是字典序...要以字典序输出路径,那么搜索的方向(我的程序是path()函数)就要以特殊的顺序排列了...这样只要每次从dfs(A,1)开始搜索,第一个成功遍历的路径一定是以字典序排列...

下图是搜索的次序,马的位置为当前位置,序号格为测试下一步的位置的测试先后顺序

按这个顺序测试,那么第一次成功周游的顺序就是字典序


 


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<malloc.h>
#include<math.h>
int p,q;
int chess[9][9];
int nextx[8]={-1,1,-2,2,-2,2,-1,1};
int nexty[8]={-2,-2,-1,-1,1,1,2,2};
char s[100];
int count;
int flag;
void dfs(int startx,int starty,int step){
    //chess[startx][starty]=1;
    //puts(s);
    if(flag)
        return;
    if(step==count){
        puts(s);
        printf("\n");
        flag=1;
        return;
    }
    int i,j;
    int x,y;
    for(i=0;i<8;i++){
        x=startx+nextx[i];
        y=starty+nexty[i];
        if(x>=0&&x<p&&y>=0&&y<q&&chess[x][y]==0){
            chess[x][y]=1;
            s[step]='A'+y;
            s[step+1]='1'+x;
            dfs(x,y,step+2);
            chess[x][y]=0;
        }
        //return;
    }
}
int main(){
    int t;
    scanf("%d",&t);
    int time=0;
    while(t--){
        time++;
        scanf("%d%d",&p,&q);
        printf("Scenario #%d:\n",time);
        if(p==1&&q==1){
            printf("A1\n\n");
            continue;
        }
        if(p*q>26||p<=2||q<=2||p>=9||q>=9){
            printf("impossible\n\n");
            continue;
        }
        count=p*q*2;
        int i,j;
        flag=0;
        for(i=0;i<q;i++){
            for(j=0;j<p;j++){
                memset(chess,0,sizeof(chess));
                memset(s,'\0',sizeof(s));
                s[0]='A'+i;
                s[1]='1'+j;
                chess[j][i]=1;
                dfs(j,i,2);
                if(flag)
                    break;
            }
            if(flag)
                break;
        }
        if(!flag){
            printf("impossible\n\n");
        }
    }
    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值