UVA 116 Unidirectional TSP

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an tex2html_wrap_inline352 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below.

picture25

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different tex2html_wrap_inline366 matrices are shown below (the only difference is the numbers in the bottom row).

picture37

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by tex2html_wrap_inline376 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10

Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1

19

给你一个m*n的整数矩阵,从第一列的任何一个位置出发每次向右,右上或者右下走一格,最终到达最后一列。要求经过的整数之和最小。整个矩形是环形的,即第一行的上方是最后一行,最后一行的下方是第一行。输出路径上每行的行号。多解释输出字典序最小的。

分析:每一列就是一个阶段,每个阶段有三种决策:直行,右上,右下。为了使字典序最小,每次让行号排个序,选择最小的行号。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
int Map[105][105];
int dp[105][105];
int Next[105][105];
int main(){
    int m,n;
    int i,j;
    int v,first;
    while(~scanf("%d %d",&m,&n)){
        for(i=0;i<m;i++){
            for(j=0;j<n;j++){
                scanf("%d",&Map[i][j]);
            }
        }
        int ans=0x7FFFFFFF;
        first=0;
        for(j=n-1;j>=0;j--){
            for(i=0;i<m;i++){
                if(j==n-1){
                    dp[i][j]=Map[i][j];
                }
                else{
                    int row[3]={i,i-1,i+1};
                    if(i==0)
                        row[1]=m-1;
                    if(i==m-1)
                        row[2]=0;
                    sort(row,row+3);
                    dp[i][j]=0x7FFFFFFF;
                    for(int k=0;k<3;k++){
                        v=dp[row[k]][j+1]+Map[i][j];
                        if(v<dp[i][j]){
                            dp[i][j]=v;
                            Next[i][j]=row[k];
                        }
                    }
                }
                if(j==0&&dp[i][j]<ans){first=i;ans=dp[i][j];}
            }
        }
        printf("%d",first+1);
        i=Next[first][0];
        for(j=1;j<n;j++){
            printf(" %d",i+1);
            i=Next[i][j];
        }
        printf("\n");
        printf("%d\n",ans);
        /*for(i=0;i<m;i++){
            for(j=0;j<n;j++){
                printf("%d ",Map[i][j]);
            }
            printf("\n");
        }*/
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值