UVA 12563 Jin Ge Jin Qu hao

12563 Jin Ge Jin Qu hao 
(If you smiled when you see the title, this problem is for you ^_^) 
For those who don’t know KTV, see: http://en.wikipedia.org/wiki/Karaoke_box 
There is one very popular song called Jin Ge Jin Qu(劲歌金曲). It is a mix of 37 songs, and is 
extremely long (11 minutes and 18 seconds) — I know that there are Jin Ge Jin Qu II and III, and 
some other unofficial versions. But in this problem please forget about them. 
Why is it popular? Suppose you have only 15 seconds left (until your time is up), then you should 
select another song as soon as possible, because the KTV will not crudely stop a song before it ends 
(people will get frustrated if it does so!). If you select a 2-minute song, you actually get 105 extra 
seconds! ….and if you select Jin Ge Jin Qu, you’ll get 663 extra seconds!!! 
Now that you still have some time, but you’d like to make a plan now. You should stick to the 
following rules: 
? Don’t sing a song more than once (including Jin Ge Jin Qu). 
? For each song of length t, either sing it for exactly t seconds, or don’t sing it at all. 
? When a song is finished, always immediately start a new song. 
Your goal is simple: sing as many songs as possible, and leave KTV as late as possible (since we 
have rule 3, this also maximizes the total lengths of all songs we sing) when there are ties. 
Input 
The first line contains the number of test cases T (T ≤ 100). Each test case begins with two positive 
integers n, t (1 ≤ n ≤ 50, 1 ≤ t ≤ 109 
), the number of candidate songs (BESIDES Jin Ge Jin Qu) 
and the time left (in seconds). The next line contains n positive integers, the lengths of each song, in 
seconds. Each length will be less than 3 minutes — I know that most songs are longer than 3 minutes. 
But don’t forget that we could manually “cut” the song after we feel satisfied, before the song ends. So 
here “length” actually means “length of the part that we want to sing”. 
It is guaranteed that the sum of lengths of all songs (including Jin Ge Jin Qu) will be strictly larger 
than t. 
Output 
For each test case, print the maximum number of songs (including Jin Ge Jin Qu), and the total lengths 
of songs that you’ll sing. 
Explanation: 
In the first example, the best we can do is to sing the third song (80 seconds), then Jin Ge Jin Qu 
for another 678 seconds. 
In the second example, we sing the first two (30+69=99 seconds). Then we still have one second 
left, so we can sing Jin Ge Jin Qu for extra 678 seconds. However, if we sing the first and third song 
instead (30+70=100 seconds), the time is already up (since we only have 100 seconds in total), so we 
can’t sing Jin Ge Jin Qu anymore!Universidad de Valladolid OJ: 12563 – Jin Ge Jin Qu hao 2/2 
Sample Input 

3 100 
60 70 80 
3 100 
30 69 70 
Sample Output 
Case 1: 2 758 

Case 2: 3 777

题意,求在给定好的时间内,最多能唱多少首歌,在最多歌的情况下,使唱歌的时间最长。类似于0—1背包,可以用0—1背包的思路解决。提前留下一秒用来唱劲歌金曲,剩下的时间用来唱其他歌。不过还有一个问题:必须对问题限定,每首歌必须恰好唱完。dp[i]表示在i时间用完的情况下刚好唱完多少首歌。这样处理时可以先算出最多能唱多少首歌,然后从最后开始遍历到的第一个唱歌数最多的就是时间最长的。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
int dp[10005];
int Time[55];
int main(){
    int i,j,k;
    int ans;
    int Max;
    int n;
    int kase;
    int t;
    scanf("%d",&kase);
    for(k=1;k<=kase;k++){
        scanf("%d %d",&n,&t);
        for(j=0;j<n;j++)
            scanf("%d",&Time[j]);
        t--;
        memset(dp,0,sizeof(dp));
        Max=0;
        for(i=0;i<n;i++){
            for(j=t;j>=Time[i];j--){
                if(dp[j-Time[i]]>=1||j==Time[i]){
                    dp[j]=max(dp[j],dp[j-Time[i]]+1);
                    if(Max<dp[j])
                        Max=dp[j];
                }
            }
        }
        printf("Case %d:",k);
        if(Max==0){
            printf(" 1 678\n");
        }
        else{
            for(i=t;i>=0;i--){
                if(Max==dp[i])
                    break;
            }
            printf(" %d %d\n",dp[i]+1,i+678);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值