poj1426

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 30495 Accepted: 12684 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111


这个题说是bfs做的,但是我是dfs做的,试过一次bfs,用的stl里面的queue,但是超时了,估计queue还是比较慢吧,后来看了人家的代码直接dfs,果然过了。

题目大意:给你一个数字,要你求一个只有0和1组成的数,并且这个数是给你的数字的倍数,答案不唯一,随便输出一个就行

在unsigned __int64范围内是可以做的

而且搜索的时候最多会搜索19层

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#include<vector>
#include<stack>
#include<set>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
bool t;
void dfs(unsigned __int64 m,int num,int k){
    if(t)
        return;
    if(m%num==0){
        t=1;
        printf("%I64u\n",m);
        return;
    }
    if(k==19)
        return;
    dfs(m*10,num,k+1);
    dfs(m*10+1,num,k+1);
}
int main(){
    int num;
    unsigned long long m,tmp;
    while(~scanf("%d",&num)&&num){
        t=0;
        dfs(1,num,0);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值