hdu1532 网络流裸题

纪念我的第一个网络流裸题

ek的算法 具体可看我的上一篇博客

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18437    Accepted Submission(s): 8721


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50
 

Source

#include<cstdio>
#include<string>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<stack>
#define ll long long
#define read(a) scanf("%d",&a);
using namespace std;
const int maxn=205;
const int inf=99999999;
int c[maxn][maxn];
bool book[maxn];
int pre[maxn];
int main(){
	freopen("test.txt","r",stdin);
	int start,end,weight;
	int n,m;
	int i,j;
	int ans;
	while(~scanf("%d %d",&m,&n)){
		memset(c,0,sizeof(c));
		for(i=0;i<m;i++){
			scanf("%d %d %d",&start,&end,&weight);
			c[start][end]+=weight;
		}
		ans=0;
		while(1){
			memset(book,false,sizeof(book));
			memset(pre,0,sizeof(pre));
			queue<int>que;
			que.push(1);
			book[1]=true;
			int mini=inf;
			while(!que.empty()){
				int num=que.front();
				if(num==n)
					break;
				//printf("%d\n",num);
				for(i=1;i<=n;i++){
					if(book[i]==false&&c[num][i]>0){
						book[i]=true;
						que.push(i);
						pre[i]=num;
						//printf("%d ",i);
						mini=min(mini,c[num][i]);
					}
				}
				//printf("\n");
				que.pop();
			}
			//printf("%d\n",mini);
			if(book[n]==false){
				//printf("!!!!!!");
				break;
			}
			int tmp=n;
			while(pre[tmp]!=0){
				c[pre[tmp]][tmp]-=mini;
				c[tmp][pre[tmp]]+=mini;
				tmp=pre[tmp];
			}
			ans+=mini;
			//printf("%d\n",ans);
		}
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值