Fat brother and Maze are playing a kind of special (hentai) game in the clearly blue sky which we can just consider as a kind of two-dimensional plane. Then Fat brother starts to draw N starts in the sky which we can just consider each as a point. After he draws these stars, he starts to sing the famous song “The Moon Represents My Heart” to Maze.
You ask me how deeply I love you,
How much I love you?
My heart is true,
My love is true,
The moon represents my heart.
…
But as Fat brother is a little bit stay-adorable(呆萌), he just consider that the moon is a special kind of convex quadrilateral and starts to count the number of different convex quadrilateral in the sky. As this number is quiet large, he asks for your help.
Input
The first line of the date is an integer T, which is the number of the text cases.
Then T cases follow, each case contains an integer N describe the number of the points.
Then N lines follow, Each line contains two integers describe the coordinate of the point, you can assume that no two points lie in a same coordinate and no three points lie in a same line. The coordinate of the point is in the range[-10086,10086].
1 <= T <=100, 1 <= N <= 30
Output
For each case, output the case number first, and then output the number of different convex quadrilateral in the sky. Two convex quadrilaterals are considered different if they lie in the different position in the sky.
Sample Input
2 4 0 0 100 0 0 100 100 100 4 0 0 100 0 0 100 10 10
Sample Output
Case 1: 1 Case 2: 0
求凸四边形的个数
把求凸四边形转化为求判定凹四边形
凹四边形:凹点与其他三个点分别围成的三角形的面积和 和 其他三个点围成的面积相等
判断面积相等 注意 浮点数作差与极小值 1e-6
#include<iostream>
#include<cmath>
using namespace std;
#define inf 1e-6
struct node{
int x;
int y;
};
double area(node a, node b, node c){
return fabs(1.0 * ((b.x - a.x)*(c.y - a.y) - (b.y - a.y)*(c.x - a.x)))*0.5;
}
bool judge(node a, node b, node c, node d){
if(fabs(area(b, c, d) - area(a, b, c) - area(a, b, d) - area(a, c, d)) < inf){
return false;
}
else return true;
}
int main(){
int t;
cin >> t;
for(int i = 1; i <= t; i++){
node uu[35];
int n;
cin >> n;
for(int j = 0; j <= n - 1; j++){
cin >> uu[j].x >> uu[j].y;
}
int sum = 0;
for(int j = 0; j <= n - 1; j++){
for(int k = j + 1; k <= n - 1; k++){
for(int r = k + 1; r <= n - 1; r++){
for(int s = r + 1; s <= n - 1; s++){
if(judge(uu[j], uu[k], uu[r], uu[s]) && judge(uu[k], uu[j], uu[r], uu[s]) && judge(uu[r], uu[j], uu[k], uu[s]) && judge(uu[s], uu[j], uu[k], uu[r])){
sum++;
}
}
}
}
}
cout<<"Case "<<i<<": "<<sum<<endl;
}
return 0;
}