A - 费马小定理

求:3^0 + 3^1 +...+ 3^(N) mod 1000000007

Input

输入一个数N(0 <= N <= 10^9)

Output

输出:计算结果

Sample Input

3

Sample Output

40
#include<bits/stdc++.h>
using namespace std;
#define c 1000000007
long long f(long long a, long long b){
    int ans = 1;
    while(b){
        if(b & 1){
            ans = (ans * a)%c;
        }
        b>>=1;
        a = (a * a) % c;
    }
    return ans;
}
int main(){
    //long long sum = 0;
    int n;
    cin >> n;
    long long t = (f(3, n + 1) - 1);
   // cout << t << endl;
   // cout << f(2, c - 20000000) << endl;
    long long b1 = t * f(2, c - 2) % c;
    cout << b1 << endl;
    return 0;
}

 

一个数有逆元的充分必要条件是gcd(a,n)=1gcd(a,n)=1,此时逆元唯一存在 
(a b)mod p=((a mod p)×(b mod p) mod p

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值